Afișarea Sumei Numerelor Pare Dintr-un Șir de N Numere Întregi

Proiect
5/10 (2 voturi)
Domeniu: Calculatoare
Conține 1 fișier: doc
Pagini : 8 în total
Cuvinte : 267
Mărime: 18.83KB (arhivat)
Cost: 4 puncte
Profesor îndrumător / Prezentat Profesorului: Ion Istudor
Afisarea sumei numerelor pare dintr-un sir de n numere întregi - rezolvare in TurboPascal si C

Cuprins

CUPRINS

1. Definirea problemei 4

2. Limbajul pseudocod 4

3. Schema logica 5

4. Programul în limbajul Turbo Pascal 6

5. Programul în limbajul C 7

6. Exemplificari 8

7. Bibliografie 9

Extras din document

1. Definirea problemei

Se citeste un numar natural n si un sir de n numere întregi.

Sa se afiseze suma numerelor pare din sir.

2. Limbajul pseudocod

a, S, i, n: întregi;

început

citeste n;

S  0;

pentru i=1,n executa;

început

citeste a;

daca a%2=0 atunci S  S+a sfârsit daca;

sfârsit; sfârsit pentru;

scrie S;

3. Schema logica

4. Programul în limbajul Turbo Pascal

program suma;

var i,n,s,a:integer;

begin

write('Introduceti numarul numerelor');

read(n);{citeste numarul numerelor}

s:=0;

Preview document

Afișarea Sumei Numerelor Pare Dintr-un Șir de N Numere Întregi - Pagina 1
Afișarea Sumei Numerelor Pare Dintr-un Șir de N Numere Întregi - Pagina 2
Afișarea Sumei Numerelor Pare Dintr-un Șir de N Numere Întregi - Pagina 3
Afișarea Sumei Numerelor Pare Dintr-un Șir de N Numere Întregi - Pagina 4
Afișarea Sumei Numerelor Pare Dintr-un Șir de N Numere Întregi - Pagina 5
Afișarea Sumei Numerelor Pare Dintr-un Șir de N Numere Întregi - Pagina 6
Afișarea Sumei Numerelor Pare Dintr-un Șir de N Numere Întregi - Pagina 7
Afișarea Sumei Numerelor Pare Dintr-un Șir de N Numere Întregi - Pagina 8

Conținut arhivă zip

  • Afisarea Sumei Numerelor Pare Dintr-un Sir de N Numere Intregi.doc

Alții au mai descărcat și

Arhitectura Calculatoarelor - Intel vs AMD

Rezultatele din testul 3DS Max 7 SPECapc Test Testul alaturat consta in crearea modelelor 3D, modificarea si randarea scripturilor. Conform...

Sistem de Prognosticare a Unei Avarii

Acest sistem calculeaza gradul de avariere a unei cladiri în cazul unui cutremur, precum si posibila necesitate a reconstructiei cladirii (partiala...

Te-ar putea interesa și

Tema PC

1. Sa se implementeze un program care sa aduca pe primul loc componenta de valoare minima în valoare absoluta si componenta de pe primul loc pe...

Ai nevoie de altceva?